Home | Profile - Edit | Your Page | Your Inbox Browse | Search Games   |   Log In

IFDB Installer - Windows Mozilla Firefox, Apple Safari, Opera

This page explains how to install the IFDB Meta Installer plug-in for the Windows version of Mozilla Firefox, Apple Safari, and Opera. These browsers use the standard Mozilla plug-in format, so the same plug-in works for any of them.

If you're not using Windows, this plug-in won't work for you - you'll need to get a plug-in for your operating system. This plug-in will not work with Internet Explorer - you need our IE ActiveX plug-in instead. If you're using a Windows browser other than IE, Firefox, Safari, or Opera, this plug-in might work, but you'll have to try it to find out. See the main installer plug-in page for other options.

Current Status